CHAPTER

4

Workbench Basics

I

n any Eclipse-based application development tool like WDSC or Rational
Developer for System i, you will come across common terminology, such
as Workbench, Workspace, perspective, view, and active editor. You need to
be familiar with the common concepts, user interface, and terminology of
Eclipse, so that you can navigate with ease in the Remote System Explorer,
Integrated i5/OS Debugger, and other Eclipse-based tools you might use in
the future.
This chapter covers the building blocks necessary to understand any
Eclipse-based tool. When you are finished with this chapter, you will have
a strong base from which to explore further.
If you are a PDM/SEU user, this chapter will introduce you to a
richer, powerful, more robust, and integrated application development
environment. If you’re an experienced RSE user, this chapter will help
raise your awareness of some common behaviors across views and tools,
and show you ways to customize your Workbench.

The Workbench
Let’s begin with the term Workbench. This refers to the overall graphical
user interface and tools that make up the development environment. Each
Workbench window contains one or more perspectives. Perspectives contain
views and editors, and control what appears in menus and toolbars.
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The Workbench toolbar is displayed at the top of the Workbench window,
directly underneath the menu bar, as shown in Figure 4–1. The toolbar’s
contents change based on the editor currently being used, also known as
the active editor. Actions in the toolbar may apply to a particular editor, so
these actions may be enabled or disabled based on the state of the currently
active view or editor.

Figure 4–1: The Workbench.

More than one Workbench window can be open on the
desktop at any given time.

Perspectives
A perspective defines the initial set and layout of views shown in the
Workbench window, along with the menu actions that are available. Each
perspective is designed to perform a particular set of tasks, and is identified
by a name and an icon. For example, when you open the Remote System
Explorer perspective, you will find tools to connect to i5/OS servers and
edit and compile source members on those servers. However, if you want
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to debug a program, you switch to
the Debug perspective.
The name of the current perspective
is shown in the title bar for the
Workbench window. You can have
many perspectives open at the same
time in a single Workbench window.
Often, you will be switching between
perspectives depending on the tasks
Figure 4–2: The perspective bar.
you are performing. The perspective
bar, shown in Figure 4–2, lists the
current open perspectives, allowing quick access to open ones. Click on a
perspective’s name and icon to switch to that open perspective.

The Workbench provides a shortcut key for switching
between open perspectives. Press Ctrl+F8 once to switch
back to the last opened perspective. Alternatively, hold down the Ctrl
key while pressing and releasing F8 to open a dialog that shows a list
of open perspectives. Continue pressing F8 while holding down the
Ctrl key until the open perspective you want is selected. Then, release
the Ctrl key. This same behavior works for views using Ctrl+F7, and for
editors using Ctrl+F6.

The perspective bar may be docked in three different positions: the upper
right corner (the default position), the upper left corner (under the main
toolbar), and to the far left. Right-clicking the perspective bar shows you
the operations available for the perspective. Click the double arrow in the
perspective bar to list additional open perspectives.
To change the size of the perspective bar, position the mouse on the edge of
the perspective bar (the mouse pointer changes to a two-sided arrow), click
the left mouse, hold, and then drag the perspective bar. Release the mouse
when the desired size is achieved. Once you are familiar with the icons for
each perspective, you will likely want to deselect the Show Text option so
more open perspectives can be shown in the perspective bar.
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As you switch between perspectives, you will see views
pertaining only to that perspective, but all the editors open
in all the perspectives are visible. This is because all perspectives within
a Workbench window share the same editor pane.

Opening a Perspective
Each product defines a default perspective, which is opened the first
time the product starts with a new Workspace. For WDSC and Rational
Developer for System i, the default perspective is the Remote System
Explorer perspective. This perspective is opened the first time you start
the Workbench.
To open a new perspective, click the “open perspective” icon (
) in
the perspective toolbar, or select Window > Open Perspective from the
menu bar. This shows a list of perspectives that are closely related to
the current one. Click Other if you do not see the perspective you want
in this list. This opens a dialog with a list of all perspectives from all
enabled capabilities. If you still do not see the one you want, select the
Show all checkbox to include perspectives from disabled capabilities.
(You’ll learn more about capabilities later in this chapter.)
Once you select a perspective to open, the title bar of the Workbench
window changes to display the perspective name. An icon and the name
are also added to the perspective bar, allowing you to quickly switch back
to the perspective from other perspectives in the same window.
By default, new perspectives open in the same Workbench window.
There is a preference to change this behavior so perspectives open in a
new Workbench window. Workbench preferences are discussed later in
this chapter.
Customizing the Perspective Layout
Perspectives can be customized to suit the needs of you, your project, and
your screen size. Depending on the size of your screen, you might not want
to see all the views at once. Views can be added, deleted, and moved within
a perspective. (This is covered in the next section.)
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When you get to the point where the layout of your perspective is a work of
art, be sure to save it for future use. You can either save the changes to the
current perspective or create a new perspective. (We recommend the second
option.) To save the perspective, select Window > Save Perspective As
from the Workbench menu. This opens a dialog box where you can enter a
new name for the perspective or select an existing perspective that you want
to overwrite. If you create a new perspective, it will be included in the list of
Workbench perspectives.
If your perspective doesn’t turn out to be such a work of art after all, reset
it back to the original layout by selecting Window > Reset perspective. To
reset modified perspectives that were installed as part of the Workbench,
use the General > Perspectives preference page. Select the perspective
from the list, and click Reset. Perspectives can also be deleted from this
preference page.
The idea behind customizing a perspective is that you can choose the views
that pertain to your development environment. It is a good idea to customize
the perspective so your Workbench is not cluttered up with views you don’t
use. Try it; you have nothing to lose. If you delete or add something you
don’t want, you can always go back to the original layout and start again.
Some users create their own custom editing perspectives
that have no views open, or all views set up as fast views
(more on this later). Since there are no views, any open
editors automatically expand to take up the whole Workbench window.
Then, the Remote System Explorer perspective can be used to open
members, and the custom editing perspective can be used for editing
source members.

Views
Views and editors are the main visual components that make up the
Workbench. In any given perspective, there is a single editor area, which
can contain multiple editors, and a number of surrounding views. Views are
usually used to navigate a hierarchy of resources and to display information
about the resources. Views can provide actions to work with the resources,
such as opening an editor or searching. Some views are read-only, while
others allow modifications to the resources.
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A view might appear by itself or with other views in a group. A view
group shows multiple views in a section of the Workbench using a tabbed
notebook, with each view represented as a tab. To activate a view that is
part of a tabbed notebook, simply click its tab.
Some features are common to both views and editors, sometimes referred
to as parts. Only a single part can be active at any time. The active part
is the one whose title bar is highlighted. It is the target for common
operations like cut, copy, and paste. Pressing Ctrl+C to copy and Ctrl+V
to paste have very different results, depending on whether, say, an editor
or the Remote Systems view is active.
The active part also determines what information is displayed in the
Workbench status bar (Figure 4–1), which is located at the bottom left
corner of the perspective. If an editor tab is not highlighted, the editor is
not active; however, views related to editing (the outline view, for example)
may still show information based on the last active editor.
Each view has its own title bar that contains the view’s name, its icon,
and optionally a toolbar. Views do not use the Workbench toolbar; this is
reserved exclusively for editors. Each view can have its own toolbar containing actions that apply only to that particular view.
Right-click a view’s tab to display a menu that contains actions to control
the size and location of the view, as shown in Figure 4–3. This is referred
to as the view’s System menu. Some of the items on the System menu
are familiar Windows actions, like move, size, minimize, and maximize.
Others, like Fast View and Detached, are specific to the Workbench and
will be covered shortly. You can also access this menu using the key
combination Alt+- (the minus key).
Many views also contain a pull-down menu, which is accessed by clicking
the upside-down arrow (
) in the view’s toolbar. This pull-down menu,
also referred to as the view’s menu, typically contains operations that apply
to the entire contents of the view, as opposed to individual items shown
in the view. Operations for sorting and filtering are normally found in the
view’s menu. This menu can also be accessed through the key combination
Ctrl+F10.
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Figure 4–3: The Properties view with its System
menu open.

You can maximize a view or editor so that it fills the entire Workbench
window. Right-click the title bar and select Maximize from the view’s
System menu. To restore the view or editor to its previous position and
size, open the menu again and select Restore.

You can maximize or restore a view or editor by doubleclicking its title bar or using the Ctrl+M keyboard shortcut.
This keyboard shortcut does not work for the Remote Systems LPEX
Editor, however, because the editor assigns a different action to this
key combination. Later in this chapter, you will learn how to assign
different key combinations to the maximize and restore actions for the
Remote Systems LPEX Editor.

Adding and Removing Views
Perspectives predefine the combination and location of views they initially
show. To open additional views, select Window > Show View from the
main menu bar. The current perspective determines which views may be
of interest and displays these on the Show View submenu. For additional
views, select Other from the Show View submenu. Selecting one of the
views will add it to a default location in the current perspective. You can
then move the view to any location you want.
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Click the X in the view’s tab, next to the view’s name, to close the view
from the current perspective, as shown in Figure 4–4.

Figure 4–4: Closing the view.

Normally, only one instance of a view exists within a Workbench window.
That view instance may be open in multiple perspectives at the same time.
So, changing the contents of the view in one perspective will be reflected
in all perspectives that have the view open.
Resizing and Moving Views
You can resize editors and views by dragging the sashes that separate them.
When you position the cursor on a sash, a double-headed arrow appears, as
shown in Figure 4–5. Drag this arrow by holding the left mouse button and
release the mouse button once the part reaches the desired size.

Figure 4–5: Resizing editors and views.

The layout of the Workbench can be rearranged by dragging views to
different positions within the Workbench window. To change the location
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of a view in the current perspective, drag the view by its title bar by holding
down the left mouse button. As you move the view around the Workbench,
the mouse pointer will change to one of the drop cursors shown in Table 4–1.
Drop cursors indicate where a view will dock when you release your mouse
button. This indication is relative to the part currently underneath the mouse
pointer. Release the left
button once the view is in
A group of stacked views can be
the location you want.
dragged using the empty space
to the right of the view tabs.

You can also drag a view
outside of the Workbench to
turn into a detached view. Alternatively, detach a view by right-clicking the
view tab and selecting Detached. To re-attach the view to the Workbench,
right-click the view and select Detached again.
Detached views can be handy if you are lucky enough to have two monitors connected to your workstation. You can display the main Workbench
window on one monitor and some key detached views on the other.
Another advantage to detached views is they stay on top of editors that are
maximized. So, you can maximize the editor and have the Outline view
or Source Prompter floating on top. (Actually, for source prompting, it
is likely easier to create a custom perspective that only shows the Source
Prompter view at the bottom of the perspective and leaves the rest of the
area for the editors.)
Table 4 1: Drop Cursors
Cursor

Name

Description

Dock above

The part will appear above the part underneath the cursor.

Dock below

The part will appear below the part underneath the cursor.

Dock to the
right

The part will appear to the right of the part underneath the
cursor.

Dock to the left

The part will appear to the left of the part underneath the
cursor.

Stack

The part will appear as a tab in the same pane as the part
underneath the cursor.

Restricted

You cannot dock the view in this area.
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Fast Views
Fast views are views that are hidden, but can quickly be made visible to
work with the view and then hidden again. They work like other views,
except they do not take up space in the Workbench window.
A fast view is handy when you want to use the view occasionally, but
do not want it to take up space or clutter up the Workbench. Fast views
are also handy because they can be shown when an editor is maximized,
without having to restore the editor. This makes the Outline view an ideal
candidate for use as a fast view.
Fast views are docked on the fast view bar, which is the horizontal toolbar
initially at the bottom left of the Workbench window. Views in fast view
mode are shown as icons on the fast view toolbar. You can make a view a
fast view in one of three ways:
●

Drag the open view to the fast view toolbar.

●

Right-click the view’s tab, and select the Fast View option.

●

Click the “Fast view” icon (
) located on the left side of the
fast view bar. This pops up a list of views, as shown in Figure 4–6.
Select a view from the list to add it to the fast view bar.

Figure 4–6: Creating fast views.

In Figure 4–6, at the bottom of the list of views, you see Other assigned to
the key combination Alt+Shift+Q, Q. Let us explain this here, and then we
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will come back to fast views. Eclipse supports key bindings that contain more
than one keystroke, and this is an example of it. Therefore, to see the list of
other views, you need to press Alt+Shift+Q together, let go, and then press Q.
It’s difficult to memorize these shortcuts, especially if you do not use them
often. To help, when you press Alt+Shift+Q, a pop-up appears showing the
possible completions for this key combination, as shown in Figure 4–7.
Choose the one you want from the list using the mouse, or type the next
letter (in this case Q), to complete the action.

Figure 4–7: Key bindings with more than one keystroke.

Back to fast views. Figure 4–8 shows an example of the fast view bar with
four views docked as fast views. Clicking the icon for a view in the fast
view bar temporarily opens the view in the current perspective. Clicking
outside the view causes the view to be hidden again.

Figure 4–8: The fast view bar with icons.

By default, the fast view bar is docked on the bottom left corner of the
Workbench. However, you can choose to dock it on the top, left, or right of
the Workbench. Position the mouse on the small vertical line immediately
before the fast view icon. (This line may be solid or dotted.) The mouse
cursor will change to a four-sided arrow, as shown in Figure 4–9. Hold
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down the left mouse button, drag the four-sided arrow to where you want
to dock the fast view bar, and then release the mouse button. Alternatively,
you can right-click the small vertical line and select one of docking
positions from the pop-up menu shown in Figure 4–10.

Figure 4–9: Dragging the four-sided
pointer to reposition the fast view bar.

Figure 4–10: The fast view bar’s docking
options.

Depending on where the fast view bar is docked, the views will be opened
in different locations in the Workbench. You might want to experiment
with this, so you have the views opening where they suit you best. The
orientation of each fast view can be set to either horizontal or vertical by
right-clicking the view’s icon and selecting one of the options from the
Orientation submenu. Some views, like the Remote Systems view, are
more usable with a vertical orientation, while others, like the Object Table
and Source Prompter, are better with a horizontal orientation.

Editors
The Workbench contains many different types of editors; each specialized
for a specific resource type. Rational Developer for System i has over 50
editors registered. WDSC has more than that. For the most part, you will
only be using the Remote Systems LPEX Editor for editing RPG, COBOL,
CL, and DDS source. If you are using WDSC AE or Rational Developer
for System i, you might also be using the Screen Designer for editing DDS
display file source, as well as the Application Diagram editor.
Each perspective typically reserves an area where editors appear. This area
appears with a grey background when no editors are open. Open editors are
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shared by all perspectives inside the Workbench. If you open an editor in
one perspective, then switch to a different perspective, the editor will still
be visible.
Multiple instances of an editor type can be open within a Workbench
window. This could be from either editing multiple files (members),
editing the same file multiple times, or a combination of both. Multiple
editors show up as tabs in the editor area, as shown in Figure 4–11.
If all the open editor tabs are not visible, you can get the full list by clicking
the
symbol or using Ctrl+E key combination. Select the file you want
to make active using
the Up and Down arrow
keys, and press Enter.
To close a file, you can right-click it in
the list of open files and select Close.

You will come across
the terms “dirty editor”
and “clean editor” when working with editors. There is nothing dirty about
it! A dirty editor is just an editor that contains unsaved changes. This is
visually represented in the editor tab by an asterisk (*) before the name of
the file, as shown in Figure 4–11. A clean editor has no unsaved changes.

Figure 4–11: Clean and dirty editors.

You will also come across the terms “editor in focus” or “active editor.”
(We used these terms earlier, as well.) They both mean the same thing.
As described earlier during the discussion of views, the active part (editor
or view) is the one currently being used. The title bar of the active part is
highlighted.
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Some Workbench views, such as the Navigator and Remote Systems views,
can be linked to the active editor. This means that closing or switching editors
changes the selection in the view to match the file open in the active editor.
You can use the “Link With Editor” icon (
) found in the view’s toolbar to
toggle the view to automatically select the current file being edited.
Tiling Editors
Open files can be grouped into sets of editors. Each editor set can contain
one or more open files. The Workbench allows more than one editor set in
the editor area at a time by tiling the sets, as shown in Figure 4–12. This
allows you to see the contents of two or more editors at the same time. It is
often referred to as “split-screen editing.” (Split-screen editing of a single
member is covered in chapter 6.)

Figure 4–12: Editors open with two editor sets tiled horizontally.

Tiling editors is accomplished the same way as moving views. Drag an
editor by clicking its editor tab and holding down the left mouse button.
Move the mouse to the left, right, top, or bottom of the editor area, and
release the left button when the mouse changes to a black arrow. The
editor will be dropped into a new editor set in the designated area.
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To tile editors vertically, drag and drop to the left or right of the editor area.
To tile horizontally, drag and drop to the top or bottom. You are not limited
to tiling only vertically or horizontally. You can mix and match until you
run out of screen space!
The list of open editors only shows the list in that particular editor set. For
example, pressing the double arrow (or using Ctrl+E) in the first editor set
in Figure 4–12 will show only the open editors in that editor set. Pressing
Ctrl+E in the second editor set will show only the open editors in that
editor set, as shown in Figure 4–13.
Can you get the list of all open editors in all editor sets? Yes, you can,
by using the Switch to Editor dialog. This can be invoked using the key
combination Ctrl+ Shift+E. Figure 4–14 shows the Switch to Editor dialog
for the example in Figure 4–13.

Figure 4–13: The open files in one editor set.

The Switch to Editor dialog displays all open editors, allowing you to
choose the ones you want to close, save, or activate. Notice that we said all
open editors, meaning that you can actually list not only editors from all
editor sets within one Workbench window, but editors open from all open
windows (from the same Workspace). To obtain this list, check the box
Show editors from all windows.
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Figure 4–14: All open editors.

Suppose you have ten members open, and you want to
close all of them except for two. Open the Switch to Editor
dialog, select the two you want to keep open, click Invert Selection,
and then click Close Selected Editors.

One key difference between views and editors is that editors cannot be
detached from the Workbench window or made into fast views.

Toolbars
In this chapter so far, you have seen many different toolbars in the
Workbench. Let’s summarize them here and put them together to see
the big picture. There are four main toolbars in the Workbench:
●

Workbench toolbar: This displays at the top of the Workbench
window, directly beneath the menu bar. The contents of this toolbar
change based on the current perspective and active editor. Items in
this toolbar may be enabled or disabled based on the state of either
the active view or editor. You can rearrange the sections of the main
toolbar.
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●

Perspective toolbar: This allows quick access to open perspectives
and has a button to open new perspectives.

●

View toolbars: These are individual toolbars that appear in the title
bar of a view. Actions in a view’s toolbar apply only to the view in
which they appear. Some view toolbars include a view menu that
contains additional actions for the view. The view menu can be
accessed by clicking the upside-down triangle.

●

Fast view bar: This contains icons representing the current set of
fast views.

You can rearrange the items in the perspective and fast view bars by
dragging and dropping them. The Workbench toolbar is broken down into
sections that can be rearranged using the mouse, but the individual items
within a section cannot be rearranged. A vertical line divides the toolbar
sections. (Depending on the operating system settings, this line may be
dotted or solid.)
You can lock the main toolbar to prevent accidental changes to it. When the
vertical line dividing the sections is visible, as in Figure 4–15, the toolbar
is unlocked. Otherwise, the toolbar is locked, as shown in Figure 4–16. To
lock and unlock a toolbar, right-click anywhere in it and select the Lock
the Toolbars menu item.

Figure 4–15: An unlocked toolbar.

Figure 4–16: A locked toolbar.

Eek, It’s a Mouse
We have come to learn that SEU and PDM users don’t like mice. At first
glance, you might think the only way to navigate through this seemingly
overwhelming Workbench is by using the mouse. However, you can
maneuver just as easily around the Workbench using the keyboard. It
jus takes a bit longer to memorize all the keyboard shortcuts.
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Table 4–2 contains some helpful keyboard shortcuts for navigating around
the Workbench, from views, to editors, to menus, and to other perspectives.
Table 4–2: General Workbench Keyboard Shortcuts
Keystroke(s)

Action

F10

Access the menus on the Workbench menu bar. (In Microsoft
Windows, Alt does the same thing.) You can traverse actions
along the menu bar using the Left and Right arrow keys. Use
the Up and Down arrow keys to traverse through the menu
actions.

Alt+mnemonic

Instead of using F10 and then traversing, you can use this
to easily activate the Workbench menu for a particular entry.
For example, Alt+W opens the Window menu.

Shift+F10

Pop up the context menu for the current view, editor, or
selected item. This is the same as right-clicking.

Ctrl+F10

Open the pull-down menu for the current view, if there is
one. For editors, it will open the menu for vertical ruler (also
known as the marker bar) on the left of the editor area.

Ctrl+F6

Cycle between open editors.

Ctrl+F7

Cycle between open views.

Ctrl+F8

Cycle between open perspectives.

Ctrl+E

Activate the editor drop-down.

Ctrl+Shift+E

Open the Switch to Editor dialog.

Esc

Use this key to close a menu. This is the same as clicking
the Cancel button on a dialog.

Keyboard
arrow keys

Use the arrow keys to navigate through list and tree views in
the Workbench. For example, you can navigate through the
entire Remote Systems view using just the arrow keys. Use
the Up and Down arrow keys to navigate through items that
are already showing. Using the Left and Right arrow keys to
collapse and expand entries, respectively.

Position by
typing

If you are in a table or tree view, and you start typing,
the view attempts to position to an entry in the view that
matches what you are typing. For example, if you are in the
Remote Systems view and you just expanded your library,
you can quickly jump to the QRPGLESRC source file by just
entering QRPGLESRC. (Chances are, you will only have to
enter part of the name.)

Many of the shortcuts listed in Table 4–2 are standard
Windows behavior and will also work in your favorite word
processor, spreadsheet, Web browser, or email program.
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A mnemonic is a single letter assigned to most control labels (such as
buttons, checkboxes, and menus) to assist in choosing an action or a
selection. A mnemonic is shown as the underlined character in the action
name or label associated with the control. To select the control using its
mnemonic, press the Alt key along with the mnemonic letter.

While working in your favorite editor or view, press
Ctrl+Shift+L to see a full list of the currently available
keyboard shortcuts. The list of keyboard shortcuts is context-sensitive,
so it only displays the shortcuts that apply in the current perspective,
editor, or view. This is a great way to learn what is available in the user
interface and to speed up your productivity by learning keyboard
shortcuts. Unfortunately, the Remote Systems LPEX Editor’s keyboard
shortcuts do not show up in this list. Chapters 6 and 7 describe the
various keyboard shortcuts that can be used with the Remote Systems
LPEX Editor.

Exiting the Workbench
Each time you exit the Workbench, its state is automatically saved. This
state includes all open perspectives, windows, and views, as well as the
content and current expansion of some views (like the Remote Systems
view). This state is restored the next time the Workbench is reopened, so it
appears exactly as it was when it was closed.
To exit the Workbench, select File > Exit from the menu bar, click the X in
the Workbench window’s title bar, or press Alt+F4. The latter two options
prompt if you really wish to exit the Workbench. This dialog includes an
option to turn off the prompting. This is the default behavior and can be
customized on the General > Startup and Shutdown preference page.
There is a subtle difference between the methods of exiting the Workbench.
The File > Exit action closes all Workbench windows, and exits. If you
just want to exit the current window (if you are using multiple Workbench
windows), use the close button (the X) or Alt+F4. The last Workbench
window to close also terminates the application.
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The Workspace
The Workspace is the local Windows directory that is used to store local
development projects, preferences, and information about the Workbench
state. It is an important part of using the Workbench and is accessed and
updated frequently.
When you first start the Workbench, the Workspace launcher dialog will
come up, asking for a Workspace location. A default location is pre-filled,
and is usually somewhere under your My Documents folder. You can change
the location by entering a new location or clicking the Browse button.
For performance reasons, it is important that you use a local
drive for your Workspace instead of the network drive.

Some users like to create multiple Workspaces to separate their work.
This might be useful if you are working on some projects that require Java
development and others that require RPG or COBOL development. You
could keep a separate Workspace for each, or you could use one Workspace
for both. We prefer to keep everything in one Workspace, to avoid losing
things! However, we usually create separate Workspaces for playing around
and experimenting.
You can also work with multiple Workspaces at the same time. To do
this, you need to start the product multiple times, specifying different
Workspace locations each time. You will then have a Workbench window
for each Workspace.
Normally, you would not have to worry about where your Workspace is
located unless you want to switch between Workspaces or back up your
Workspace (generally a good idea). To switch between Workspaces, select
Switch Workspace from the File menu.
To show the Workspace location in the Workbench title, add the
-showlocation command-line parameter to the end of the target field in
the Windows shortcut properties for WDSC or Rational Developer for
System i, as shown in Figure 4–17. If you use multiple Workspaces, you
may find the -data workspaceLocation command-line parameter useful.

Workspace Migration

This parameter tells WDSC or Rational Developer for System i to use the
specified Workspace and not prompt for the Workspace location.

Figure 4–17: Showing the location of the Workspace
in the Workbench window.

Suppose you selected the “Use this as the default and do
not ask again” option on the Workspace launcher dialog, but
now you really wish it would ask you again. Use the preference on the
General > Startup and Shutdown preference page to turn this back on.

Workspace Migration
When upgrading to a newer version of the product, pay close attention to
the migration guide. Sometimes, the layout of the Workspace or the way
information is stored in the Workspace changes between versions of the
product.
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Your Workspace contains all of your RSE connections, filters, preferences,
and other customizations. You will likely want to migrate your old Workspace to work with the new version of the product. Guidance on Workspace
migration is provided in the migration guide.
After your Workspace has been migrated to the newer version, it might
not work with the previous version anymore. Be sure to back up your
Workspace before migrating.

Common Workbench Icons
Table 4–3 lists some of the common icons used in the Workbench and the
actions they represent.
Table 4–3 Common Icons Used in the Workbench
Icon
Meaning
Remove the selected item from the list.
Remove all the items from the list.
Clear the contents of the view.
Link with the editor.
Refresh the information for the view or for the selected
resources.
Minimize the view.
Maximize the view.
Filter.
Search.
Move back to the previous contents of the view or preference
page. This works like the Back button on a Web browser.
Move forward to the next contents of the view or preference
page. This works like the Forward button on a Web browser.

Customizations
Many aspects of the appearance and behavior of the Workbench can
be customized to suit your individual style. You’ve already seen how
to customize the layout of a perspective, the toolbars, the size, and the
position of the views. In addition, you can control several other key
aspects of a perspective through the Preferences and the Customize
Perspective dialogs.

Customizations

Preferences
Each tool that plugs into the Workbench defines preferences that can be
customized by users, and there are lots of them! The good news is that the
preferences are centralized in one place. The Preferences dialog is used
to set user preferences for all aspects of the Workbench. Open it from the
Workbench window menu under Window > Preferences.
You can search the Preferences dialog pages using the filter function, as
shown in Figure 4–18. To filter by matching the page title, simply type
the name of the page you are seeking. The pages that match will be listed
below. The history controls (
) allow you to navigate forward
and backward through previously viewed pages. To step back or forward
several pages at a time, click the drop-down arrow. A list of the most
recently viewed preference pages will appear. You can select from this
list the preference page you want to view.

Figure 4–18: Searching and traversing preference pages.

The intent here is not to explain each and every preference pertaining to
the Workbench. Relevant preferences are covered in each chapter of this
book. Below, we highlight some general Workbench preferences to appreciate the extent to which the Workbench can be customized. Let’s start by
looking at the General > Perspectives preference page (Figure 4–19). Here
you can do the following:
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●

Choose to open a new Workbench window for each new perspective
that is opened. The default is to open in the same window.

●

Choose to open new views as fast views. The default is that the view
will be opened within the perspective.

●

Choose to switch to the appropriate perspective when creating new
projects.

●

Change the default perspective that is opened when the Workbench
starts, by selecting the perspective from the list of available
perspectives and clicking the Make Default button. You can see
here that the default perspective for Rational Developer for System
i is the Remote System Explorer. You can also delete user-deﬁned
perspectives and reset the perspectives installed with the Workbench
to their default settings if they have been modiﬁed.

Figure 4–19: Perspective preferences.

Customizations

To make the preferences take effect, click Apply or OK. Each preference
page has a Restore Defaults button that sets the preferences on the page to
the defaults shipped with the Workbench.
If you choose the option to open perspectives in different windows, you
can see the list of all open windows from the Window menu, as shown in
Figure 4–20. The name of the window is the name of the current active
perspective in that window.

Figure 4–20: A list of open Workbench windows.

You can have the same perspective open in two different
windows. The fastest way to do this is from the perspective
itself, going to Window > New Window. This opens a new Workbench
window with the same perspective as the current perspective.

You can customize many other aspects of the Workbench. Go through each
of the preference pages on the left-hand pane of the Preferences dialog
(Appearance, Editors, and Startup and Shutdown, for example), and use the
right-hand pane to customize that preference.
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Capabilities
One other preference page worth mentioning is Capabilities. The Workbench
is designed to have multiple tools plugged into it, such as tools for i5/OS
application development, Java, and XML. Many of these tools provide a
capability that can be enabled or disabled. Disabling the capability hides the
user interface for the related tools.
By default, a limited set of capabilities are enabled when you start
the product, to reduce the clutter that appears in the Workbench. The
available views and menu actions depend on the capabilities enabled in
the Workbench.
Once you start using the Workbench as your primary development
environment, you might want to enable more of the capabilities that are
not enabled by default. (All of the i5/OS application development tools
are enabled by default.) You can find the list of capabilities on the General
> Capabilities preference page. Try to add and remove capabilities and
see how the items available in certain menus, like Window > Show view,
changes.
Keyboard Shortcuts
Command is a term used by the Workbench to refer to actions such as cut,
copy, prompt, or find date. Keyboard shortcuts are predefined for many
of the Workbench commands. The General > Keys preference page allows
you to view and modify the keyboard shortcuts.
Two pieces of information are required when associating a keyboard
shortcut with a command: the key sequence, and when the shortcut is
valid. The View tab of the Keys preference page lists all currently defined
keyboard shortcuts. Using the Modify tab, shown in Figure 4–21, you can
add and remove keyboard shortcuts.
Using the Command section of the preference page, you can select a
category and command to see what keyboard shortcuts are currently
assigned to the command. Using the Key Sequence area, you can enter
a key sequence (by pressing the actual keyboard shortcut) to see what
commands the key sequence is currently assigned to.

Customizations

Figure 4–21: The Keys preference page.

To delete a keyboard shortcut, select one of the assignments and click the
Remove button. To add a new keyboard shortcut, follow these steps:
1. Select the command in the Command area.
2. Enter the key sequence in the Key Sequence area.
3. Select when the keyboard shortcut should be available.
4. Click the Add button.
You will quickly learn that most key sequences are already associated to
one or more commands. Figure 4–21 shows that the Ctrl+Shift+A key
sequence is assigned to the command to open an editor in the Remote
Systems LPEX Editor. You can also see that this key sequence is assigned
to the Occurrences in File command. This is fine, since the keyboard
shortcuts are valid in different contexts (when editing in structured test
editors for the “Occurrence in File” command, and when in windows for
the “Open a member in Remote Systems LPEX Editor” command).
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Customizing the Menus
In addition to configuring the layout, you can control several other key
aspects of a perspective, including the following:
●

The File > New menu

●

The Window > Open Perspective menu

●

The Window > Show View menu

●

Action sets that show up on the Workbench menu bar and toolbar

Select Window > Customize Perspective to customize any one of these
items. This opens the Customize Perspective dialog, which contains two
tabs: Shortcuts and Commands. The Shortcuts tab, shown in Figure 4–22,
can be used to customize what appears in the File > New, Window >
Perspective, and Window > Show View menus.
Figure 4–22 shows an example of customizing the Open perspective menu.
Using the drop-down menu, choose Open Perspective. Then, select as
many perspectives as you want from the list on the right. For example,
select the Debug, Remote System Explorer, and Test perspectives, as
shown in Figure 4–22. Open the Window > Open Perspective submenu to
see the three perspectives selected, as shown in Figure 4–23.

Figure 4–22: Customizing the Open Perspective menu.

Getting Help

Figure 4–23: The Open Perspective menu.

The Commands tab can be used to customize what actions appear in
the menu bar and the toolbar. The leftmost column lists all the available
command groups. Selecting a command group shows which actions are
added to the menu bar and toolbar if that particular command group is
selected. Figure 4–24 shows the menu bar and toolbar details for CVS
command group.

Figure 4–24: Customizing the menu bar and toolbar.

Getting Help
The Workbench help system lets you browse, search, bookmark, and
print the documentation shipped with the product. The documentation is
grouped into sets of information that are analogous to books. Help can
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be displayed in the Workbench using the Help view or the separate Help
window.

Help View
The Help view, shown in Figure 4–25, displays help inside the main
Workbench window. Open the view from the Workbench menu by selecting
Help > Dynamic Help or by pressing F1 from any Workbench view.

Figure 4–25: The Help view.

The Help view consists of several pages. Each one provides different help
functions. Hyperlinks at the bottom of the Help view enable you to switch
among the following pages:
●

Related Topics shows help topics related to the current Workbench
context (view or action). The About section shows help speciﬁc to
your current context, and the Dynamic Help section shows some
search results that may (or may not) be related.

●

All Topics shows the table of contents for the help.

Getting Help

●

Search allows searching local help, tutorials gallery, IBM
developerWorks, Google, Eclipse.org, and the samples gallery.
Links to search hits are displayed, along with a summary of topic
contents. To add other Internet resources to the search, expand the
Search Scope section of the search page and click the Advanced
Settings link.

●

Index provides an index of keywords that link to speciﬁc help pages,
similar to an index found at the back of a book. As you type in the
text ﬁeld, the best match will automatically be highlighted in the
list of keywords. This page will only appear when index content is
available in the Workbench.

●

Bookmarks displays your list of personal bookmarks in the help.

When on the Related Topics page, the contents of the Help view change
automatically as you switch views to show the context-sensitive help for
the active view. Figure 4–25 shows the help for the Commands Log view in
the Remote System Explorer perspective. This context-sensitive help page
includes three hyperlinks into the main help documentation.

Help Window
The Help window, shown in Figure 4–26, also provides access to the
documentation, but in a separate window instead of in a view. To open the
window from the main menu, select Help > Help Contents. The first view
shown in the window is the Contents view. It displays the table of contents
for the product documentation.

Figure 4–26: The external Help window.
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To navigate the Help window, find the topic you want to read in the table
of contents by clicking to expand the subtopics. Most help pages provide a
list of links to related topics at the bottom. Follow these links to learn more
about related features. Use the navigation buttons to go back and forth,
get back to the home page, synchronize the topic to the help contents, and
bookmark the topic.
Some users find it difficult to locate the help they are
looking for using the Contents view in the main Help
window. Instead, try showing the context-sensitive help for the related
view (by pressing F1 in the view), and then using the hyperlinks to link
into the related documentation page. The Help view includes an icon in
its toolbar to open the current page in the external Help window when
displaying pages from the product documentation. Once in the external
Help window, you can use the icon in the navigation buttons to show
the current page in the contents.

Help Preferences
The way help is displayed can be customized on the Help preference page,
shown in Figure 4–27. For example, you display help in an external Web
browser instead of the Help window.

Figure 4–27: Preferences for getting help.
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Context Help
If you’re working through a task and encounter something you don’t
understand, you can ask for context help. This opens the Help view,
showing information about the view, editor, dialog, or action you are
currently using, and possibly some links to topics for further help. Context
help can be accessed by pressing the F1 key. Alternatively, in dialogs, you
can achieve the same result by pressing the “help” button (
) in the
dialog’s button bar.
You can configure context help to display using infopops instead of the
Help view on the Help preference page. An infopop is an alternate way of
presenting context-sensitive help, where a small window displays the help
and links to related online help topics. Figure 4–28 shows the same help as
in Figure 4–25, using an infopop instead of the Help view.

Figure 4–28: Help in an infopop.

Context-sensitive help is unavailable for toolbar buttons.
Instead, let your mouse pointer hover over a toolbar button
to view tooltip help for the button.

Searching
The help system includes a search engine that can run simple or complex
queries on the documentation to help you find the information you are
looking for. To search the help, select Help > Search from the Workbench
menu, type the word or phrase you want to search for, and press Enter or
click Go. The search results display as hyperlinks below the search entry
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field. Alternatively, you can search from the Help window using the Search
field at the top of the window.
The first time you search the online help, the help system might start an
index-generation process. This process of building the indexes for the
search engine to use might take several minutes, depending on the amount
of documentation and whether pre-built indexes are installed. The results of
the search will be available once the indexing process completes. You can
continue to use help while the index is being built.
The search expression is case insensitive, meaning it ignores the case of the
words. The search expression uses regular expression rules. For example,
you can surround your search words with double quotes to search for the
exact match. You can also use the asterisk or question mark wildcards, or
the Boolean operators (AND, OR, NOT).
The search engine uses fuzzy searches and word stemming. If you enter
create, for example, it returns topics that contain creates, creating, creator,
and so on. To prevent the search engine from stemming terms, enclose
them in double quotes.
You can limit the search to a subset of the documentation by clicking on
the Search Scope hyperlink beside the search entry field in the main Help
window. Here, you specify a name for a search list and select the topics
you want to include in the search. The search scope is remembered across
Workbench invocations, so always remember to check it before searching.

Bookmarks
Bookmarks are a simple and quick way to navigate to help pages that you
frequently use. To bookmark a help page, click the “bookmark document”
icon ( ) when the topic you want to bookmark is displayed. This adds the
topic to the list of bookmarks. You can access your bookmarks by clicking
the bookmark page in the Help view or clicking the “bookmarks” icon ( )
at the bottom left corner of the Help window, as shown in Figure 4–29.

Getting Help

Figure 4–29: A Help window with bookmarks.

You can delete a particular bookmark using the “delete selected topic” icon
(
) in the toolbar for the Bookmarks pane of the Help window. Alternatively, delete all bookmarks using the “delete all topics” icon (
).
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